XLM Withdrawals under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted 3 months ago. Dec 19, 2018 - 15:22 UTC
Update
We are continuing to investigate this issue.
Posted 3 months ago. Dec 13, 2018 - 21:17 UTC
Investigating
We are currently investigating this issue.
Posted 3 months ago. Dec 11, 2018 - 21:09 UTC
This incident affected: Crypto Withdrawals and Crypto Deposits.