CEX.IO Broker Under Maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jul 05, 2020 - 09:57 UTC
Investigating
We are currently investigating this issue.
Posted Jul 05, 2020 - 09:26 UTC