XLM Transactions Unstable
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted about 1 month ago. Dec 11, 2018 - 11:47 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 month ago. Dec 11, 2018 - 10:24 UTC
This incident affected: Crypto Withdrawals and Crypto Deposits.