XRP transactions under maintenance.
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Dec 09, 2019 - 12:35 UTC
Investigating
We are currently investigating this issue.
Posted Dec 09, 2019 - 12:08 UTC
This incident affected: Crypto Deposits (XRP) and Crypto Withdrawals (XRP).