CEX.IO Broker under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Aug 09, 2019 - 13:53 UTC
Update
We are continuing to work on a fix for this issue.
Posted Aug 08, 2019 - 22:39 UTC
Update
We are continuing to work on a fix for this issue.
Posted Aug 08, 2019 - 22:27 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 08, 2019 - 20:00 UTC