LINK withdrawals are under the maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Nov 18, 2020 - 10:42 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 17, 2020 - 18:18 UTC
This incident affected: Crypto Withdrawals (Chain Link (LINK)).