SRM withdrawals are under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jun 03, 2021 - 20:07 UTC
Investigating
We are currently investigating this issue.
Posted Jun 03, 2021 - 07:20 UTC
This incident affected: Crypto Withdrawals (SRM).