MHC withdrawals are under the maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Apr 14, 2021 - 13:35 UTC
Investigating
We are currently investigating this issue.
Posted Apr 14, 2021 - 12:51 UTC
This incident affected: Crypto Withdrawals (MHC).