ADA deposits/withdrawals under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jan 12, 2020 - 11:26 UTC
Investigating
We are currently investigating this issue.
Posted Jan 12, 2020 - 09:04 UTC
This incident affected: Crypto Withdrawals (ADA) and Crypto Deposits (ADA).