Customer Support System is on maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Apr 15, 2021 - 19:00 UTC
Investigating
We are currently investigating this issue.
Posted Apr 15, 2021 - 16:29 UTC
This incident affected: Uptime (Customer Support).