Trade MKR/USD and COMP/USD is under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jun 15, 2021 - 16:15 UTC
Investigating
We are currently investigating this issue.
Posted May 26, 2021 - 12:52 UTC