We are observing network performance issues, CEX.IO Broker might be inaccessible from some locations.
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Aug 08, 2019 - 10:10 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 08, 2019 - 08:24 UTC