Withdrawals XRP are under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Apr 09, 2021 - 06:33 UTC
Update
We are continuing to investigate this issue.
Posted Apr 08, 2021 - 22:42 UTC
Investigating
We are currently investigating this issue.
Posted Apr 08, 2021 - 22:41 UTC
This incident affected: Crypto Withdrawals (XRP).