CEX.IO BROKER Under Maintenance on 17.01 from 9:30 till 10:00 UTC
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jan 17, 2020 - 10:35 UTC
Investigating
We are currently investigating this issue.
Posted Jan 17, 2020 - 08:59 UTC