NEO withdrawals are under maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Jan 22, 2022 - 07:43 UTC
Investigating
We are currently investigating this issue.
Posted Jan 15, 2022 - 18:04 UTC
This incident affected: Crypto Withdrawals (NEO).