SRM withdrawals maintenance
Incident Report for CEX.IO
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 08:25 UTC
Update
We are continuing to investigate this issue.
Posted Jan 11, 2024 - 15:27 UTC
Investigating
We are currently investigating this issue.
Posted Dec 09, 2022 - 09:25 UTC
This incident affected: Crypto Withdrawals (SRM).