Luna Classic (LUNC) transactions maintenance
Incident Report for CEX.IO
Update
We are continuing to investigate this issue.
Posted Jan 11, 2024 - 15:26 UTC
Investigating
We are currently investigating this issue.
Posted Sep 12, 2023 - 10:33 UTC
This incident affects: Crypto Deposits (LUNC) and Crypto Withdrawals (LUNC).